Ga door naar hoofdinhoud

Repareer je spullen

Recht op reparatie

Winkel

Help

Origineel bericht door: harald ,

Tekst:

This most likely cause by a dead AMD GPU. As this Mac also has an internal (Intel) GPU some things might work just fine. Running the ASD EFI version will usually claim all is fine. The ASD OS version on the other hand will usually crash during boot.

As the problems in the dead GPUs are caused by connections coming loose between the silicon die and the carrier that the die is mounted on, and there are very many of those connections, there are also very many different symptoms of having a dead GPU.

1) The most obvious, and tell tale, is when there are coloured lines or coloured blocks or bars in the image on the screen. As the GPU drives the screen even a non-technical user will understand the problem is the GPU.

There are more symptoms however that are more devious, and are nevertheless still caused by the GPU...

2) During booting the Mac freezes with the progress bar stuck about half way. This is the point where the OS switches control to the external GPU. Sometimes the Mac will actually still be running but the image on the screen is no longer updated. This can sometimes be noticed from the busy light when booting from an external drive or the fact that the Mac will respond to keys being pressed on the keyboard (volume up or down for example).

This can be tested by running ASD EFI which does not use the external GPU. All the tests in ASD EFI will pass, yet ASD OS will not even boot.

Things can get even more devious however...

3) During POST (Power On System Test) the Mac tries to talk to the GPU. It is possible for the GPU to fail in ways that cause the POST to crash, rather than give an error. From the users point of view the Mac will simply refuse to turn on. Even the experienced repair technician may not realise that the GPU is the cause. If you open the Mac you will notice that the fans do start spinning when you turn on the Mac.

Test this by removing the RAM. If you now get a long beep indicating 'no RAM detected' you know that the Mac is in fact running. As the RAM is checked before the GPU this test still works even with a dead GPU, giving us a vital clue as to what is going on.

A further test could be to remove R8911 (which we have to remove when placing the Tiresias anyway) and reinstall the memory. This turns off the AMD GPU. Now the Mac will no longer crash in the POST, and although the screen will be black, the Mac should give the start-up chime when turned on.

In all the above cases installing a CMIzapper Tiresias and removing R8911 will bring the Mac back to life!

Status:

open