Ga door naar hoofdinhoud
Help

Deze versie is geschreven door: Basti ,

Titel:

iMac A1418 late 2013 dead Power Supply / repair possible?

Tekst:

Hi all,
 
today I took a known good power supply of the above mentioned iMac A1418 (late 2013) and put it in another iMac (same model) so I could test its functionality.
 
Well, as soon as I plugged in the power cord to this iMac I heard a noisy sound (bang) and the main fuse of the domestic electricity circuit got kicked out. To be honest I have no idea where this came from as I didn't even pushed the power button to start up the iMac.
 
There is obvious damage at the PSU as you can see in the pictures. I switched the PSU to my own iMac again and none of the status LEDs lights up (no fuse gets kicked either).
 
[image|1493290]
 
[image|1493291]
 
 
By reinstalling the PSU to the testing iMac again, same thing happened.
 
How likely would a shorted power plug of the testing iMaciMac's case be? Does anyone know where to get schematics for this PSU (model APA007 from Acbel Polytech INC.) and is it possible to get it repaired?!
How likely would a shorted power plug of the testing iMaciMac's case be? Does anyone know where to get schematics for this PSU (model APA007 from Acbel Polytech INC.) and is it possible to get it repaired?!
 
Any help appreciated ;-)

Apparaat:

iMac Intel 21.5" EMC 2638

Status:

open

Bewerkt door: Basti ,

Titel:

iMac A1418 late 2013 dead Power Supply / repair possible?

Tekst:

Hi all,
 
today I took a known good power supply of the above mentioned iMac A1418 (late 2013) and put it in another iMac (same model) so I could test its functionality.
 
Well, as soon as I plugged in the power cord to this iMac I heard a noisy sound (bang) and the main fuse of the domestic electricity circuit got kicked out. To be honest I have no idea where this came from as I didn't even pushed the power button to start up the iMac.
 
There is obvious damage at the PSU as you can see in the pictures. I switched the PSU to my own iMac again and none of the status LEDs lights up (no fuse gets kicked either).
 
[image|1493290]
[image|1493291]
 
 
By reinstalling the PSU to the testing iMac again, same thing happened.
 
How likely would a shorted power plug of the testing iMac case be? Does anyone know where to get schematics for this PSU (model APA007 from Acbel Polytech INC.) and is it possible to get it repaired?!
How likely would a shorted power plug of the testing iMac case be? Does anyone know where to get schematics for this PSU (model APA007 from Acbel Polytech INC.) and is it possible to get it repaired?!
 
Any help appreciated ;-)

Apparaat:

iMac Intel 21.5" EMC 2638

Status:

open

Bewerkt door: Basti ,

Titel:

iMac A1418 late 2013 dead Power Supply / repair possible?

Tekst:

Hi all,
 
today I took a known good power supply of the above mentioned iMac A1418 (late 2013) and put it in another iMac (same model) so I could test its functionality.
 
Well, as soon as I plugged in the power cord to this iMac I heard a noisy sound (bang) and the main fuse of the domestic electricity circuit got kicked out. To be honest I have no idea where this came from as I didn't even pushed the power button to start up the iMac.
 
There is obvious damage at the PSU as you can see in the pictures. I switched the PSU to my own iMac again and none of the status LEDs lights up (no fuse gets kicked either).
 
By reinstalling the PSU to the testing iMac again, same thing happened.
 
How likely would a shorted power plug of the testing iMac case be? Does anyone know where to get schematics for this PSU (model APA007 from Acbel Polytech INC.) and is it possible to get it repaired?!

Any help appreciated ;-)
How likely would a shorted power plug of the testing iMac case be? Does anyone know where to get schematics for this PSU (model APA007 from Acbel Polytech INC.) and is it possible to get it repaired?!

Any help appreciated ;-)

Apparaat:

iMac Intel 21.5" EMC 2638

Status:

open

Origineel bericht door: Basti ,

Titel:

iMac A1418 late 2013 dead Power Supply / repair possible?

Tekst:

Hi all,

today I took a known good power supply of the above mentioned iMac A1418 (late 2013) and put it in another iMac (same model) so I could test its functionality.

Well, as soon as I plugged in the power cord to this  iMac I heard a noisy sound (bang) and the main fuse of the domestic electricity circuit got kicked out. To be honest I have no idea where this came from as I didn't even pushed the power button to start up the iMac.

There is obvious damage at the PSU as you can see in the pictures.  I switched the PSU to my own iMac again and none of the status LEDs lights up (no fuse gets kicked either).

By reinstalling the PSU to the testing iMac again, same thing happened.

How likely would a shorted power plug of the testing iMac case be? Does anyone know where to get schematics for this PSU (model APA007 from Acbel Polytech INC.) and is it possible to get it repaired?!

Apparaat:

iMac Intel 21.5" EMC 2638

Status:

open