Skip to main content
Help

Deze versie is geschreven door: Nen ,

Titel:

Desoldering copper pad melted - salvageable?

Tekst:

Hello,

Using an iron, desoldering pump. I did not use flux. I attempted to desolder my mouse switches for Mouse 1 and Mouse 2, and replace them. When trying to replace the switches, the result was : Mouse 1 worked properly, while mouse 2 didn't respond. Clearly there is an issue with it.

On the back side of the PCB, the copper plate is clearly not even there anymore, while it looks like it's fine on the front side.

'''Question:''' Is there any way to salvage this? If not, If i had to redo this, what could I do better to make sure it doesn't happen again?

Here is what it looks like:

[image|1488986]

[image|1488988]

[image|1488987]

[image|1488985]

[image|1488984]

Apparaat:

Mouse

Status:

open

Goedgekeurd antwoord:

495755

Origineel bericht door: Nen ,

Titel:

Desoldering copper pad melted - salvageable?

Tekst:

Hello,

Using an iron, desoldering pump. I did not use flux. I attempted to desolder my mouse switches for Mouse 1 and Mouse 2, and replace them. When trying to replace the switches, the result was : Mouse 1 worked properly, while mouse 2 didn't respond. Clearly there is an issue with it.

On the back side of the PCB, the copper plate is clearly not even there anymore, while it looks like it's fine on the front side.

'''Question:''' Is there any way to salvage this? If not, If i had to redo this, what could I do better to make sure it doesn't happen again?

Here is what it looks like:

[image|1488986]

[image|1488988]

[image|1488987]

[image|1488985]

[image|1488984]

Apparaat:

Mouse

Status:

open