Ga door naar hoofdinhoud

Origineel bericht door: Jeff Beacham ,


My wifes 3yr old Note 8 GT-N 5110 was working fine, she had almost no power left so she put it on charge overnight and the next day all she had was a black screen. I like most people found the first and obvious thing was to replace the charging socket as this takes quite a hit with the one way fitting. Still no joy and so I left it and gave her my Lenovo to use instead. A week ago, I bought another complete working 5110 for $56AU on eBay with a cracked screen and a well used body. So, I tested it and as stated it was a fully working concern. First I swapped the battery over, ...Nothing. Tried the charging port,....Nothing.  Ok, swap over the Logic board, back in with the new charging port and a 90% charged battery, power on and yippee..! All is good now, well apart from the fact that whatever was on the old system is gone. No problem though, it's all on playstore and can be re installed.  So, it seems that the logic/motherboard is the failure here and only after 3 years of careful use.  It is only used to study language classes and looks as good as the day it was bought.