Ga door naar hoofdinhoud
Help

Origineel bericht door: Eugene Cheng ,

Tekst:

I am just wondering it's 2017 now...and the only sales now on ebay are all v1.1.

Will they be compatible with v1.0 (broken original)?

Status:

open