Ga door naar hoofdinhoud
Help

Deze versie is geschreven door: oldturkey03 (stem details) ,

Titel:

Touch issues after 7 plus screen install replacement

Tekst:

So I had this happen today  with two installation attempts with two different phones and two different replacement screens.   I'm putting a new screen on an iPhone 7 Plus and the screen tests fine prior to install, yet when it's fully inserted into the frame, the touch screen functionality goes erratic and is basically non-usable.  The second screen I was dealing was SUPPOSED to be OEM quality (I'm having my doubts on that supplier) so I was really surprised to have any issues.  I had the chance to tinker with that one a lot more than the first and the different was obvious, the screen is fully connected and everything installed on the back of it and it tests totally fine while it's outside of the frame.  But as soon as it goes in all the way, it's worthless.  Now, this guy, and the first, now that I think of it, had some rather significant bends in their frames that I couldn't straighten out completely.  However, the original screens, once reinstalled, worked just fine so perhaps it's just an issue with some of the aftermarket screens being rather finicky.  I should note that 3d touch was turned off.

Does anyone know if this is somehow to the installation of the new screens?  At any rate, it's extremely frustrating only having an issue flare up once you're all the way through the repair.

Apparaat:

iPhone 7 Plus

Status:

open

Goedgekeurd antwoord:

394867

Origineel bericht door: FixNcell Phone Repair ,

Titel:

Touch issues after 7 plus screen install replacement

Tekst:

So I had this happen today  with two installation attempts with two different phones and two different replacement screens.   I'm putting a new screen on an iPhone 7 Plus and the screen tests fine prior to install, yet when it's fully inserted into the frame, the touch screen functionality goes erratic and is basically non-usable.  The second screen I was dealing was SUPPOSED to be OEM quality (I'm having my doubts on that supplier) so I was really surprised to have any issues.  I had the chance to tinker with that one a lot more than the first and the different was obvious, the screen is fully connected and everything installed on the back of it and it tests totally fine while it's outside of the frame.  But as soon as it goes in all the way, it's worthless.  Now, this guy, and the first, now that I think of it, had some rather significant bends in their frames that I couldn't straighten out completely.  However, the original screens, once reinstalled, worked just fine so perhaps it's just an issue with some of the aftermarket screens being rather finicky.  I should note that 3d touch was turned off.

Does anyone know if this is somehow to the installation of the new screens?  At any rate, it's extremely frustrating only having an issue flare up once you're all the way through the repair.

Apparaat:

iPhone 7 Plus

Status:

open