Ga door naar hoofdinhoud
Help

Origineel bericht door: david ,

Tekst:

Hi Andrzej,

I am not sure if this will entirely solve your problem but it should at least answer a few of your questions.

The metal panel that you removed serves as a heat barrier between the screen and the internal components of the iPhone as the backlight can generate a fairly large amount of heat.  It also serves as an electromagnetic barrier to prevent the high voltages used for the backlight/screen from adversely affecting the phones internal components. I would suggest you reinstall it but thats up to you.

As for why Touch ID isn't working, there are a few potential causes. It could be that the metal barrier not being there is causing interference with the cable, so I would first try reinstalling that. Then check the contacts of the cable, and make sure the connection points are clean (95% isopropyl alcohol and a q tip with some type to dry are great cleaners). It could also be that you tore/kinked the cable when reinstalling: in which case replacing the cable should fix the problem.  If you have a multimeter (5$ on amazon) you could test this, comment if you want more specifics on that.

There is also the possibility that you damaged one or more of the connectors when replacing this item and that is causing the connection issue. If the connector damage is only on the cable, replacement should still work. If the other components are damaged, I am not sure what the solution to this problem would be (if there is one), as there are a lot of external factors involved.

From my experience, sometimes when disconnecting/reconnecting these cables, just leaving it will fix it. I had an iPhone say the Touch ID was unable to be initialized and then one month later it started working again, randomly...

Hope this helps!

Status:

open