Ga door naar hoofdinhoud
Help

Deze versie is geschreven door: oldturkey03 (stem details) ,

Titel:

Logic board or Psu?

Tekst:

I have a mid 2007 intel iMac 20" that won't power on. When I plug the ac adapter in the first led comes on. When I press the power button led's 2 and 3 come on and the fan spins at regular speed and the optical drive starts up. Led 4 never comes on so I think its an LCD or video card problem. Do I need to test the Psu or is it the logic board or the video card? Thanks in advance!

Apparaat:

iMac Intel 20" EMC 2133 and 2210

Status:

open

Goedgekeurd antwoord:

36730

Bewerkt door: Jonathan ,

Titel:

Logic board or Psu?

Tekst:

I have a mid 2007 intel iMac 20" that won't power on. When I plug the ac adapter in the first led comes on. When I press the power button led's 2 and 3 come on but nothing else happens and ledthe fan spins at regular speed and the optical drive starts up. Led 4 never comes on. No fan spinon so I think its an LCD or optical drive sounds and the screen stays blackvideo card problem. Do I need to test the Psu or is it the logic board or the video card? Thanks in advance!
I have a mid 2007 intel iMac 20" that won't power on. When I plug the ac adapter in the first led comes on. When I press the power button led's 2 and 3 come on but nothing else happens and ledthe fan spins at regular speed and the optical drive starts up. Led 4 never comes on. No fan spinon so I think its an LCD or optical drive sounds and the screen stays blackvideo card problem. Do I need to test the Psu or is it the logic board or the video card? Thanks in advance!

Apparaat:

iMac Intel 20" EMC 2133 and 2210

Status:

open

Origineel bericht door: Jonathan ,

Titel:

Logic board or Psu?

Tekst:

I have a mid 2007 intel iMac 20" that won't power on. When I plug the ac adapter in the first led comes on. When I press the power button led's 2 and 3 come on but nothing else happens and led 4 never comes on. No fan spin or optical drive sounds and the screen stays black. Do I need to test the Psu or is it the logic board or the video card? Thanks in advance!

Apparaat:

iMac Intel 20" EMC 2133 and 2210

Status:

open