Ga door naar hoofdinhoud
Help

Origineel bericht door: jayeff ,

Tekst:

Hi,

You say that you had to ''manouevre'' the charger to make the phone start to charge.

It may be that you have either a faulty or loose charge port in the phone.

Try the following in case it is something simple that you can easily fix.

''Do not open the phone as it will void your warranty.''

Using a magnifying glass and a strong light, visually inspect the charge port (USB port) from the outside of the phone.  Ensure that the 'pins' are all there (usually there are 5) and that they are all straight and parallel with each other. Also ensure that the port does not have any lint or dust trapped in it. If it has then try to remove it using a vacuum cleaner so as to not damage the pins as you might if you use a sharp implement. If you have too, ''gently'' use a wooden toothpick to remove any lint.

If the USB port looks OK and as you say that you have only had the phone for 5 months and that there is a 12 month manufacturer's warranty on the phone , I suggest that you verify the purchase date of the phone and then consult the warranty documentation that came with the phone as to what you have to do to make a claim for a warranty repair or replacement.

If you cannot find the documentation here is a link to the Blu warranty provisions for the USA, if that is where you are.

http://bluproducts.com/images/US_Limited%20Warranty_BLU_Products.pdf

Be aware that if they find that for example the USB port has become dislodged from the systemboard they may reject your warranty claim on the basis that you caused the problem by using excessive force when inserting a USB cord or charger. I'm not saying that you did or that they will or they wont, it's  just that you are aware of the warranty provisions and what they do and do not cover.

Status:

open