Ga door naar hoofdinhoud
Help

Origineel bericht door: Dan ,

Tekst:

Only the newer Mac mini requires the Torx T8 security bit driver as Apple altered things. Your Mid 2010 does not need it.

Status:

open